Survey Access Troubleshooting - How to?

Respondents cannot access the Survey

First step for troubleshooting. Goto:

  • Login »  Surveys
Click on the Survey Name or the Edit link for the survey and test the survey using the Preview link provided. If you can access the Survey then it should work fine for all.

I can access the Survey from My Account however, respondents still cannot access the Survey

Please ask the respondents to check their Internet Connectivity. This can be done by accessing sites like Google, Yahoo, etc.

Respondents receive the following message: The Requested Survey ID XXXX could not be found.

This message is displayed when the Survey ID is not found or refers to a deleted Survey. You can check the Survey ID for your survey under the Edit Survey tab. Under the Edit Survey tab you will find the unique URL to your survey that reads as follows:

http://www.QuestionPro.com/akira/TakeSurvey?id=XXXXXX where XXXXXX will be your unique Survey ID.

Make sure the Survey ID for your survey and the one the respondents are trying to access is the same.

Respondents cannot click on the link in the email to open the survey?

Some email clients for security reasons disable clickable links in emails. Please ask users to copy the entire link and paste it in the browser address bar. They should then be able to respond to your survey.

Respondent receive a message saying they have already completed the Survey

When a survey is accessed from a computer a cookie is saved on the local machine. If there is a cookie on the machine already and another respondent tries to access the survey, they might get this message. Simply ask them to delete cookies and try taking the survey. You can also disable checking cookies for the surveys. For more information please visit the Enabling Users to take the Survey multiple times (without warning) help item in addtional references.

My respondents told me that the got this error : "Method Not Allowed : /error/connnection.html" - What does that mean?

This error most likely is caused when the system is getting updated (system upgrades/security patches etc.). Usually your respondents should never see this error, but in some cases this error may show up while we are in the process of updating our system depending upon how long the end-user's session is active.